Ensenso SDK on Ubuntu 22.04

General Information

  • Product: N32-1602-16-BL, UI5240CP-C-HQ
  • Serial Number: 171251, 4103125154
  • Ensenso SDK Version: 3.6.1621
  • Operating System: Linux


Hi, I’ve been trying to get a N35 camera to work on my machine, but am encountering some issues. Firstly, the installation of the UEye drivers is not working in one simple go: when unpacking the ids-software-suite-linux-64-4.96.1-debian.tgz file from here and running dpkg -i ueye* which returns a bunch of dependency warnings. I worked around this by running:
unlink /opt/ids/ueye/lib/x86_64-linux-gnu/libueye_api.so.4.96
apt-get install --fix-broken
(If the unlink isn’t there it will complain about the file already existing)

Secondly, once the the UEye drivers and Ensenso SDK are (or at least seem to be) install and I run the Network Wizard in the NxView application, the N35 camera shows up as an UI524xTE-M. Additionally both camera’s are labled as in use while nothing is running (that I know of).

I’ve tried to run things on a windows machine and there the installation and configuration went smooth. Both camera’s show up correctly and I’m able to gather data. I also performed a firmware update on both devices here.

Would anyone have an idea how to get these camera’s to work on Ubuntu? Thanks in advance!

Hi, first thing I recommend to check is the network setting.

If the network is properly configured, the camera should run in NxView or in the IDS uEye cockpit. To check whether there is an issue with the IDS uEye driver or the Ensenso SDK, try to open the N35 in the IDS uEye Cockpit. The N35 should be listed there as UI524xTE-M. The image of an N35 will be left and right N35-image, displayed as one single image with double width.

If the camera runs in IDS uEye cockpit, it should also run in NxView.

You’ve mentionend, that you’re running two cameras. If both cameras has to share 1 Gbit/s bandwidth, please check, if the bandwithlimit of both cameras is properly set to a maximum of 500 MBit/s (Default for two cameras in NxView is 450 MBit/s)

You’ll find that value in NxTreeEdit following the provided path. NxTreeEdit can be opened via NxView/Tools or from your installation folder.

Thanks for your reply!

It turned out to be an networking issue. UEye Camera Manager mentioned the following: Status of device 1001: The network adapter is not configured to use packets larger than the normal sice of 1,5KB. Please set the packet size to be at least 2 KB. I tried to set it as mention in your documentation of network settings, but ethtool wouldn’t allow me.

This probably had to do with the network adapter I was using: switching to an usb-c to ethernet dongle solved the issue